Move SRC_URI and SRC_REV to the .inc file

Add suuport to run sdbus++ to generate code from error yaml.

Change-Id: I5bc8e5d7c0d6f511e0022fea812bdab3e833f894
Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
diff --git a/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb b/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
index fde9593..6211efa 100644
--- a/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
+++ b/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
@@ -1,12 +1,14 @@
 SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
 DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
-HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
 PR = "r1"
 
 inherit autotools pkgconfig
 inherit obmc-phosphor-license
 inherit obmc-phosphor-ipmiprovider-symlink
 inherit obmc-phosphor-utils
+inherit pythonnative
+
+require ${PN}.inc
 
 DEPENDS += "phosphor-ipmi-host"
 DEPENDS += "autoconf-archive-native"
@@ -14,6 +16,7 @@
 DEPENDS += "phosphor-logging"
 DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
 DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
+DEPENDS += "sdbus++-native"
 
 RDEPENDS_${PN} += " \
         sdbusplus \
@@ -24,9 +27,6 @@
 
 TARGET_CFLAGS += "-fpic"
 
-SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
-SRCREV = "17346b00a17a1b5202758fdfbffef8c2c065044d"
-
 HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
 
 S = "${WORKDIR}/git"