Move phosphor-gevent to http and enable nginx on 443

phosphor-gevent will be moved to internal http,
nginx will be the front end web server, and will
redirect all traffic internally to gevent.

test cases passed with...
tox -e palmetto -- tests/test_rest_interfaces.robot

Testing:
- Before testing suite completed in 1:18
  After nginx control 443 suite finished in 0:45 seconds
- Also verified web interface still loads when going
  to system name in web browser (http and https)
- Verified code update with full 20MB image still works
- Verified dump can be generated and retrieved
- Verified that when the same IP requests 2 image uploads
  at same time, Nginx serializes them

Change-Id: Ifcd61cf22bd8f6ea0536fe706eba8e45ec85e7c3
Signed-Off-by: Chris Austen <austenc@us.ibm.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-ibm/recipes-phosphor/phosphor-gevent/phosphor-gevent.bbappend b/meta-ibm/recipes-phosphor/phosphor-gevent/phosphor-gevent.bbappend
new file mode 100644
index 0000000..6dd263b
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/phosphor-gevent/phosphor-gevent.bbappend
@@ -0,0 +1,4 @@
+SUMMARY = "Modifications to support Nginx"
+
+# override service and socket file to use nginx
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"