openbmc: Add systemd service for croserver

The upstream application does not ship a systemd service file so we
include it in meta-openpower.

The service does not have an 'install' section as it should be started
on demand by the cronus user. This may change in the future if OpenBMC
gains the ability to put itself in a debug state, where starting the
croserver will be part of that process.

Change-Id: Iaeed510702e0562c00c21ffdcfa17985d0ea4e0d
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/recipes-bsp/ecmd/croserver_git.bb b/recipes-bsp/ecmd/croserver_git.bb
index a788e61..01005f8 100644
--- a/recipes-bsp/ecmd/croserver_git.bb
+++ b/recipes-bsp/ecmd/croserver_git.bb
@@ -7,6 +7,8 @@
 SRCREV = "6c0348b12c95b3bd6e8d8003f9ff743d25400ae2"
 DEPENDS += "python-native zlib"
 
+SRC_URI += "file://croserver.service"
+
 S = "${WORKDIR}/git"
 
 # Add the hash style option here to Work around this warning:
@@ -26,4 +28,9 @@
 do_install() {
     install -d ${D}${bindir}
     install -m 0755 out_obj/lib/server1p ${D}${bindir}/croserver
+
+    install -d ${D}${systemd_system_unitdir}
+    install -m 0644 ${WORKDIR}/croserver.service ${D}${systemd_system_unitdir}/
 }
+
+FILES_${PN} += "${systemd_system_unitdir}/croserver.service"