Service to scan hub chip on second processor

New openfsi driver code requires user space to explicitly
scan the second processors fsi hub to ensure no conflict
between it and the host.

User space code will use this service to do this scan
at the appropriate time.

Change-Id: I6806ec637e3b00cbba63b7dfd49a14e19cc8f713
Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
diff --git a/common/recipes-phosphor/fsi/op-fsi.bb b/common/recipes-phosphor/fsi/op-fsi.bb
index 26cab2c..0638c3d 100644
--- a/common/recipes-phosphor/fsi/op-fsi.bb
+++ b/common/recipes-phosphor/fsi/op-fsi.bb
@@ -15,7 +15,12 @@
 INSTFMT_BIND = "fsi-bind@{0}.service"
 FMT_BIND = "../${TMPL_BIND}:${TGTFMT}.requires/${INSTFMT_BIND}"
 
-SYSTEMD_SERVICE_${PN} += "${TMPL_SCAN} ${TMPL_BIND} fsi-enable.service fsi-disable.service"
+TMPL_HUB = "fsi-hub-scan@.service"
+INSTFMT_HUB = "fsi-hub-scan@{0}.service"
+FMT_HUB = "../${TMPL_HUB}:${TGTFMT}.requires/${INSTFMT_HUB}"
+
+SYSTEMD_SERVICE_${PN} += "${TMPL_SCAN} ${TMPL_BIND} fsi-enable.service fsi-disable.service ${TMPL_HUB}"
 
 SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_SCAN', 'OBMC_CHASSIS_INSTANCES')}"
 SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_BIND', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_HUB', 'OBMC_CHASSIS_INSTANCES')}"