blob: 5d1c9fd3a50ff8fc249d60203ec0e328f8820ed4 [file] [log] [blame]
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -05001SUMMARY = "Open POWER DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-license
9inherit pythonnative
10
11DEPENDS += "autoconf-archive-native"
12DEPENDS += "sdbus++-native"
13
14PACKAGE_BEFORE_PN = "${PN}-yaml"
15
16FILES_${PN}-yaml = "${datadir}/${PN}/yaml"
17
18SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces"
19SRCREV = "0862409f256cf29020d8f5fbb865fd711618b51f"
20
21DEPENDS_remove_class-native = "sdbus++-native"
22DEPENDS_remove_class-nativesdk = "sdbus++-native"
23
24PACKAGECONFIG ??= "libopenpower_dbus"
25PACKAGECONFIG[libopenpower_dbus] = " \
26 --enable-libopenpower_dbus, \
27 --disable-libopenpower_dbus, \
28 systemd sdbusplus, \
29 libsystemd sdbusplus \
30 "
31
32PACKAGECONFIG_remove_class-native = "libopenpower_dbus"
33PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus"
34
35BBCLASSEXTEND += "native nativesdk"