os-release: Don't rebuild everytime

Update the os-release recipe such that it is not rebuilt unless
git reports something different.

To do this both the recipe and sstate caches must be disabled
but the impact with such a small recipe is low enough to be
acceptable.

Resolves: openbmc/openbmc#124

Change-Id: I53343410d973ab4a60d9437704c34dbec7120ede
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-core/os-release/os-release.bbappend b/common/recipes-core/os-release/os-release.bbappend
index 9c599ee..c81eae6 100644
--- a/common/recipes-core/os-release/os-release.bbappend
+++ b/common/recipes-core/os-release/os-release.bbappend
@@ -1,3 +1,10 @@
+# WARNING!
+#
+# These modifications to os-release disable the bitbake parse
+# cache (for the os-release recipe only).  Before copying
+# and pasting into another recipe ensure it is understood
+# what that means!
+
 def run_git(d, cmd):
     try:
         oeroot = d.getVar('COREBASE', True)
@@ -20,5 +27,6 @@
 }
 
 OS_RELEASE_FIELDS_append = " BUILD_ID"
-do_compile[nostamp] = "1"
-do_compile[vardepsexclude] = "BUILD_ID VERSION VERSION_ID NAME PRETTY_NAME"
+
+# Ensure the git commands run every time bitbake is invoked.
+BB_DONT_CACHE = "1"