phosphor-software-manager: Add usr-local.mount to common code

The usr-local.mount service file does not depend on a ubi
filesystem layout, so move it out to the common code.

Change-Id: I6c4b3c394b4aac358319a9e3f2ac0f51e44079c7
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/recipes-phosphor/flash/phosphor-software-manager_git.bb b/recipes-phosphor/flash/phosphor-software-manager_git.bb
index 588c55f..bdd95df 100644
--- a/recipes-phosphor/flash/phosphor-software-manager_git.bb
+++ b/recipes-phosphor/flash/phosphor-software-manager_git.bb
@@ -58,6 +58,7 @@
 FILES_${PN}-updater += " \
     ${bindir}/phosphor-image-updater \
     ${bindir}/obmc-flash-bmc \
+    /usr/local \
     "
 FILES_${PN}-sync += " \
     ${bindir}/phosphor-sync-software-manager \
@@ -70,6 +71,11 @@
 
 SYSTEMD_SERVICE_${PN}-updater += " \
     obmc-flash-bmc-setenv@.service \
+    usr-local.mount \
 "
 
 S = "${WORKDIR}/git"
+
+do_install_append() {
+    install -d ${D}/usr/local
+}