Add systemd unit file for bios upgrade

Added a sample bios upgrade systemd unit file as a part of image updater.
user needs to add packageconfig flash_bios in bbappend file for using bios
upgrade feature.

Change-Id: If605c0b75da5e18ea846214ea0a15b4943bb7195
Signed-off-by: Vijay Khemka <vijaykhemka@fb.com>
diff --git a/recipes-phosphor/flash/phosphor-software-manager_git.bb b/recipes-phosphor/flash/phosphor-software-manager_git.bb
index bdd95df..58271c2 100644
--- a/recipes-phosphor/flash/phosphor-software-manager_git.bb
+++ b/recipes-phosphor/flash/phosphor-software-manager_git.bb
@@ -26,6 +26,7 @@
 PACKAGECONFIG[verify_signature] = "--enable-verify_signature,--disable-verify_signature"
 PACKAGECONFIG[sync_bmc_files] = "--enable-sync_bmc_files,--disable-sync_bmc_files"
 PACKAGECONFIG[ubifs_layout] = "--enable-ubifs_layout"
+PACKAGECONFIG[flash_bios] = "--enable-host_bios_upgrade"
 
 inherit autotools pkgconfig
 inherit obmc-phosphor-dbus-service
@@ -74,6 +75,8 @@
     usr-local.mount \
 "
 
+SYSTEMD_SERVICE_${PN}-updater += "${@bb.utils.contains('PACKAGECONFIG', 'flash_bios', 'obmc-flash-host-bios@.service', '', d)}"
+
 S = "${WORKDIR}/git"
 
 do_install_append() {