phosphor-certificate-manager: Add recipe and certificate service

Add recipe and service files to start/stop nginx and nslcd services

To start/stop nginx service use
systemctl stop phosphor-certificate-manager@nginx.service
systemctl start phosphor-certificate-manager@nginx.service

To start/stop nslcd service use
systemctl stop phosphor-certificate-manager@nslcd.service
systemctl start phosphor-certificate-manager@nslcd.service

Change-Id: I81c544ea9290792df0d9d2e5afb4ea2614f8e306
Signed-off-by: Marri Devender Rao <devenrao@in.ibm.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb b/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb
new file mode 100644
index 0000000..9dd6739
--- /dev/null
+++ b/recipes-phosphor/certificate/phosphor-certificate-manager_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Phosphor Certificate Manager"
+DESCRIPTION = "Manages client and server certificates"
+HOMEPAGE = "https://github.com/openbmc/phosphor-certificate-manager"
+
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI = "git://github.com/openbmc/phosphor-certificate-manager"
+SRCREV = "0aa0d11489cc8cfe4bf2662d138909eba96ccd04"
+
+inherit autotools \
+        pkgconfig \
+        obmc-phosphor-systemd
+
+DEPENDS = " \
+        phosphor-logging \
+        autoconf-archive-native \
+        phosphor-dbus-interfaces \
+        phosphor-dbus-interfaces-native \
+        sdbusplus \
+        sdbusplus-native \
+        "
+
+S = "${WORKDIR}/git"
+
+CERT_TMPL = "phosphor-certificate-manager@.service"
+SYSTEMD_SERVICE_${PN} = "${CERT_TMPL}"