logging: virtual refactoring

Remove the phosphor-logging virtuals.  They were unused.

Add a logging packagegroup so other layers can add additional
logging applications predicated on the logging distro feature
being enabled.

Change-Id: Ic82843cb2b1229df55005bad93576c14f468073b
Tested: Built witherspoon, palmetto and qemu images
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb b/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
index e7fe370..2199e03 100644
--- a/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
+++ b/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
@@ -15,6 +15,7 @@
         ${PN}-host-state-mgmt \
         ${PN}-inventory \
         ${PN}-leds \
+        ${PN}-logging \
         ${PN}-sensors \
         ${PN}-software \
         ${PN}-host-check-mgmt \
@@ -78,6 +79,11 @@
         ${VIRTUAL-RUNTIME_obmc-led-monitor} \
         "
 
+SUMMARY_${PN}-logging = "Logging applications"
+RDEPENDS_${PN}-logging = " \
+        phosphor-logging \
+        "
+
 SUMMARY_${PN}-sensors = "Sensor applications"
 RDEPENDS_${PN}-sensors = " \
         ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \