Add build time dependencies to python for skeleton

Skeleton now invokes python setuptools to install its python
applications in a top level makefile, so a build time dependency
on native-python is required.

It should be noted that skeleton invoking python from make is
an interim thing until its python applications get their own
repository.

Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/skeleton/skeleton.bb b/common/recipes-phosphor/skeleton/skeleton.bb
index 9762792..4dc9dff 100644
--- a/common/recipes-phosphor/skeleton/skeleton.bb
+++ b/common/recipes-phosphor/skeleton/skeleton.bb
@@ -16,7 +16,7 @@
 
 VIRTUAL-RUNTIME_skeleton_workbook ?= ""
 
-DEPENDS += "glib-2.0 systemd"
+DEPENDS += "glib-2.0 systemd python"
 RDEPENDS_${PN} += "python-subprocess python-compression libsystemd ${VIRTUAL-RUNTIME_skeleton_workbook}"
 SRC_URI += "git://github.com/openbmc/skeleton"