Split Rocket startup from REST application

Enable drop-in replacement of WSGI application hosts
with PREFERRED_PROVIDER_virtual/obmc-wsgihost.

Change-Id: Ieaa4b17cb4645bfc3224aca2edebb15d023982d5
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/interfaces/phosphor-rest.bb b/common/recipes-phosphor/interfaces/phosphor-rest.bb
index 3fda832..b03b245 100644
--- a/common/recipes-phosphor/interfaces/phosphor-rest.bb
+++ b/common/recipes-phosphor/interfaces/phosphor-rest.bb
@@ -1,28 +1,31 @@
-SUMMARY = "Phosphor DBUS REST Server"
-DESCRIPTION = "Phosphor DBUS REST manager."
+SUMMARY = "Phosphor DBUS to REST WSGI Application"
+DESCRIPTION = "Phosphor DBUS to REST WSGI Application."
 HOMEPAGE = "http://github.com/openbmc/phosphor-rest-server"
 PR = "r1"
 LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
 
 inherit allarch
 inherit obmc-phosphor-systemd
 inherit setuptools
 
+RRECOMMENDS_${PN} += "virtual-obmc-wsgihost"
+
 RDEPENDS_${PN} += " \
         python-xml \
         python-dbus \
-        python-pygobject \
         obmc-mapper \
-        python-rocket \
         python-bottle \
         python-spwd \
-        python-netserver \
         pyphosphor-utils \
         pyphosphor-dbus \
+        pyphosphor-wsgi-apps-ns \
         "
 SRC_URI += "git://github.com/openbmc/phosphor-rest-server"
 
-SRCREV = "803c6f1be7f589043c817a2b00fac5b0af93d200"
+SRCREV = "2c6fc760919cc214413874d60489e3643b639692"
 
-S = "${WORKDIR}/git"
+S = "${WORKDIR}/git/module"
+SYSTEMD_SERVICE_${PN} = ""
+SYSTEMD_OVERRIDE_${PN} += "rest-dbus.conf:obmc-mapper.target.d/rest-dbus.conf"
+SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/wsgi_app"