Split Rocket startup from REST application

Enable drop-in replacement of WSGI application hosts
with PREFERRED_PROVIDER_virtual/obmc-wsgihost.

Change-Id: Ieaa4b17cb4645bfc3224aca2edebb15d023982d5
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/interfaces/phosphor-rocket.bb b/common/recipes-phosphor/interfaces/phosphor-rocket.bb
new file mode 100644
index 0000000..0d93f23
--- /dev/null
+++ b/common/recipes-phosphor/interfaces/phosphor-rocket.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Phosphor Rocket startup script"
+DESCRIPTION = "Phosphor Rocket startup script."
+HOMEPAGE = "http://github.com/openbmc/phosphor-rest-server"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit allarch
+inherit setuptools
+inherit obmc-phosphor-systemd
+
+PROVIDES += "virtual/obmc-wsgihost"
+RPROVIDES_${PN} += "virtual-obmc-wsgihost"
+
+RDEPENDS_${PN} += " \
+        python-rocket \
+        "
+SRC_URI += "git://github.com/openbmc/phosphor-rest-server"
+
+SRCREV = "2c6fc760919cc214413874d60489e3643b639692"
+
+S = "${WORKDIR}/git/servers/rocket"