image-overlay: select fitimage based on obmc-ubi-fs

When the obmc-ubi-fs feature is enabled we should use the raw Linux
kernel fitImage rather than the kernel+initramfs.  Update
image-overlay to select based on the MACHINE_FEATURE.

Change-Id: I099e37c7f82218a2a7173de93724301b9a499bd3
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/classes/image_types_phosphor.bbclass b/classes/image_types_phosphor.bbclass
index 565e43c..21febe7 100644
--- a/classes/image_types_phosphor.bbclass
+++ b/classes/image_types_phosphor.bbclass
@@ -18,7 +18,9 @@
 # The reference BMC software update implementation.
 
 # Image composition
-FLASH_KERNEL_IMAGE ?= "fitImage-${INITRAMFS_IMAGE}-${MACHINE}.bin"
+FLASH_KERNEL_IMAGE ?= "${@bb.utils.contains('MACHINE_FEATURES', \
+        'obmc-ubi-fs', 'fitImage-${MACHINE}.bin', \
+        'fitImage-${INITRAMFS_IMAGE}-${MACHINE}.bin', d)}"
 IMAGE_BASETYPE ?= "squashfs-xz"
 OVERLAY_BASETYPE ?= "jffs2"
 FLASH_UBI_BASETYPE ?= "${IMAGE_BASETYPE}"