Support uploading multiple certificates per authority service

Since the certificate manager can support multiple certificates
the CERTPATH for mode=authentication will be changed to directory.

This change depends on anothere review, see Depends-On tag.

Becase the TrustStore will be used by TLS authentication,
any operation on certificates should result in bmcweb restart, that
is why #Units to restart entry is added.

Since update procedure will not replace configuration file in /etc
all configuration files for the certificate-manager will be deployed
in /usr/share/phosphor-certificate-manager.

Signed-off-by: Zbigniew Kurzynski <zbigniew.kurzynski@intel.com>
Change-Id: I9c179751742e913faf633a7654e22ad0654fbb37
diff --git a/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config.bb b/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config.bb
index f15fc73..07302d6 100644
--- a/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config.bb
+++ b/recipes-phosphor/certificate/phosphor-nslcd-authority-cert-config.bb
@@ -11,8 +11,10 @@
 
 SRC_URI = "file://env"
 
+FILES_${PN} = "${datadir}"
+
 do_install() {
-	install -D ${WORKDIR}/env ${D}/${sysconfdir}/default/obmc/cert/authority
+	install -D ${WORKDIR}/env ${D}/${datadir}/phosphor-certificate-manager/authority
 }
 
 pkg_postinst_${PN}() {