Switch to systemd state management

Enable systemd chassis and bmc state management support for Phosphor.

Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Change-Id: I180496eb8e48dfc617f944053b8e909210c6df7d
diff --git a/common/recipes-phosphor/obmc-phosphor-sys/obmc-mgr-system.bb b/common/recipes-phosphor/obmc-phosphor-sys/obmc-mgr-system.bb
index accd7da..b59833e 100644
--- a/common/recipes-phosphor/obmc-phosphor-sys/obmc-mgr-system.bb
+++ b/common/recipes-phosphor/obmc-phosphor-sys/obmc-mgr-system.bb
@@ -3,7 +3,7 @@
 PR = "r1"
 
 inherit skeleton-python
-inherit obmc-phosphor-systemd
+inherit obmc-phosphor-dbus-service
 
 VIRTUAL-RUNTIME_skeleton_workbook ?= ""
 
@@ -25,3 +25,6 @@
 do_install_append() {
 	oe_runmake -C ../hacks install DESTDIR=${D}
 }
+
+DBUS_SERVICE_${PN} += "org.openbmc.managers.System.service"
+SYSTEMD_SERVICE_${PN} += "startup-hacks.service"