sdbusplus: use python3

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I154b3d441e0710849aacc85e899d2d347a749f77
diff --git a/recipes-extended/sdbusplus/sdbusplus_git.bb b/recipes-extended/sdbusplus/sdbusplus_git.bb
index 1709906..2fa4379 100644
--- a/recipes-extended/sdbusplus/sdbusplus_git.bb
+++ b/recipes-extended/sdbusplus/sdbusplus_git.bb
@@ -2,7 +2,7 @@
 DESCRIPTION = "C++ bindings for systemd dbus APIs."
 
 inherit autotools pkgconfig
-inherit obmc-phosphor-python-autotools
+inherit obmc-phosphor-python3-autotools
 
 include sdbusplus-rev.inc
 
@@ -13,6 +13,8 @@
         ${PYTHON_PN}-pyyaml-native \
         "
 
+SRC_URI += "file://0001-sdbus-switch-to-python3.patch"
+
 PACKAGECONFIG ??= "libsdbusplus transaction"
 PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
 PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"