rsyslogd: Install default server config
This reverts commit 37bc1a3568f2e87987be05243627a984dc051de1.
In addition, it changes the default rsyslog server config to
ignore all messages. Also bumps up phosphor-logging:
phosphor-logging: srcrev bump f59854e94b..0a0b5ea558
Santosh Puranik (1):
rsyslod: Change disable action
Tested:
Verified that the default rsyslog behavior is to now ignore
all messages.
Signed-off-by: Santosh Puranik <santosh.puranik@in.ibm.com>
Change-Id: I2342fad00306d6d39042e243c4be8ebee8cd54b4
diff --git a/recipes-extended/rsyslog/rsyslog_%.bbappend b/recipes-extended/rsyslog/rsyslog_%.bbappend
index 3901844..0a2fb33 100644
--- a/recipes-extended/rsyslog/rsyslog_%.bbappend
+++ b/recipes-extended/rsyslog/rsyslog_%.bbappend
@@ -2,9 +2,15 @@
SRC_URI += " \
file://rsyslog.conf \
+ file://server.conf \
"
PACKAGECONFIG ??= " \
rsyslogd rsyslogrt inet regexp uuid \
${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
"
+
+do_install_append(){
+ install -m 0644 -D ${WORKDIR}/server.conf \
+ ${D}${sysconfdir}/rsyslog.d/server.conf
+}