Keep fan services running until poweroff completes

All the fan services associated with controlling, monitoring and
presence detection of fans need to remain active until a poweroff
completes. This helps ensure thermal safety while a system is in
transition to a powered off state.

With the introduction of this new target (which runs last in
the power off path), need to move the host reset service to
running after it to ensure the power on in the reboot path
does not start until the last power off target runs.

Resolves openbmc/openbmc#2762

Change-Id: I4ca671d2c7de66e8bfa4bba607b06c88c0a6e7f9
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/common/recipes-core/systemd/obmc-targets.bb b/common/recipes-core/systemd/obmc-targets.bb
index 1061470..26fbcd1 100644
--- a/common/recipes-core/systemd/obmc-targets.bb
+++ b/common/recipes-core/systemd/obmc-targets.bb
@@ -18,9 +18,10 @@
 # Chassis action power targets
 # - on:  Services to run to power on the chassis
 # - off: Services to run to power off the chassis
+# - powered-off: Services to run once chassis power is off
 # - reset: Services to check chassis power state and update chassis "on" target
 # - hard-off: Services to force an immediate power off of the chassis
-CHASSIS_ACTION_TARGETS = "poweron poweroff powerreset hard-poweroff"
+CHASSIS_ACTION_TARGETS = "poweron poweroff powered-off powerreset hard-poweroff"
 
 # Track all host synchronization point targets
 # - start-pre:                 Services to run before we start host boot