python3-sdbus++: switch to native setuptools3

The sdbusplus repository now has a real setup.py file that doesn't
require autotools generation.  Switch to a normal setuptools3
recipe.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ie850b527bc6ce3c2ef4a68e2c3081d60243f3c35
diff --git a/recipes-extended/sdbusplus/python3-sdbus++_git.bb b/recipes-extended/sdbusplus/python3-sdbus++_git.bb
index bf815ce..9d89895 100644
--- a/recipes-extended/sdbusplus/python3-sdbus++_git.bb
+++ b/recipes-extended/sdbusplus/python3-sdbus++_git.bb
@@ -1,11 +1,20 @@
 SUMMARY = "sdbus++ dbus API / binding generator"
 DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs"
 
-inherit autotools pkgconfig
-inherit obmc-phosphor-python3-autotools
+inherit setuptools3
 
 include sdbusplus-rev.inc
 
+## The sdbusplus repository has an Apache LICENSE file, which we would
+## normally check here, but the python setup script is in a subdirectory
+## which requires us to set ${S} below.  When we change ${S} from the root
+## of the repository, bitbake can no longer find the LICENSE file.  Point
+## to the common Apache license file in poky's meta instead.
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+S="${WORKDIR}/git/tools"
+
 # Provide these aliases temporarily until everyone can move over to the
 # new package name.
 PROVIDES_class-native += "sdbusplus-native"
@@ -24,8 +33,4 @@
     ${PYTHON_PN}-pyyaml \
     "
 
-PACKAGECONFIG ??= "transaction"
-PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
-PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
-
 BBCLASSEXTEND += "native nativesdk"