Remove S and SRC_URI from c daemon class
Initially this could be done in one place but as
sources move to git repositories this can't be done
in a generic manner.
Adapted existing recipes to this class change.
diff --git a/classes/obmc-phosphor-c-daemon.bbclass b/classes/obmc-phosphor-c-daemon.bbclass
index e21d17c..0ceed96 100644
--- a/classes/obmc-phosphor-c-daemon.bbclass
+++ b/classes/obmc-phosphor-c-daemon.bbclass
@@ -4,14 +4,12 @@
inherit obmc-phosphor-license
DEPENDS += "glib-2.0"
-SRC_URI += " \
- file://Makefile \
- file://${PN}.c \
- "
-S = "${WORKDIR}"
+
+INSTALL_NAME ?= "${PN}"
+BIN_NAME ?= "${INSTALL_NAME}"
do_install_append() {
# install the binary
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/${PN} ${D}${sbindir}
+ install -m 0755 ${S}/${BIN_NAME} ${D}${sbindir}/${INSTALL_NAME}
}