busybox: patch "umount: ignore -c"

Upstream busybox has a change to ignore the -c option, which systemd
uses when unmounting during shutdown/reboot. Currently, if -c is used,
umount fails. This results in extensive umount failures during shutdown.

See http://lists.busybox.net/pipermail/busybox/2018-January/086045.html

Resolves openbmc/openbmc#2511

Change-Id: Ic32628bf22a134012c61cb817479a86d5187f9e9
Signed-off-by: Eddie James <eajames@us.ibm.com>
diff --git a/common/recipes-core/busybox/busybox_%.bbappend b/common/recipes-core/busybox/busybox_%.bbappend
index e6678fc..5acaf3c 100644
--- a/common/recipes-core/busybox/busybox_%.bbappend
+++ b/common/recipes-core/busybox/busybox_%.bbappend
@@ -3,3 +3,4 @@
 SRC_URI += "file://flash.cfg"
 SRC_URI += "file://mountpoint.cfg"
 SRC_URI += "file://0001-Stop-watchdog-first-on-startup.patch"
+SRC_URI += "file://0001-umount-ignore--c.patch"