phosphor-settings: bump and use .inc for SRC_URI

Change-Id: If9a464c49336154f88c74e8c65012740af0672bd
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/common/recipes-phosphor/settings/phosphor-settings.bb b/common/recipes-phosphor/settings/phosphor-settings.bb
index 0653e2e..191a389 100644
--- a/common/recipes-phosphor/settings/phosphor-settings.bb
+++ b/common/recipes-phosphor/settings/phosphor-settings.bb
@@ -9,6 +9,8 @@
 inherit obmc-phosphor-dbus-service
 inherit pythonnative
 
+include phosphor-settings-manager.inc
+
 DBUS_SERVICE_${PN} = "org.openbmc.settings.Host.service"
 
 DEPENDS += "python-pyyaml-native"
@@ -16,11 +18,8 @@
 PROVIDES += "virtual/obmc-settings-mgmt"
 RPROVIDES_${PN} += "virtual-obmc-settings-mgmt"
 
-SRC_URI += "git://github.com/openbmc/phosphor-settingsd"
 SRC_URI += "file://merge_settings.py"
 
-SRCREV = "672219903522547fbef7258748521c96bf86705c"
-
 S = "${WORKDIR}/git"
 
 # Collect files in SRC_URI that end in ".override.yml" and call a script that