Add recipe support for bios-settings-mgr

- This commit would add the recipe support for the
  openbmc/bios-settings-mgr.

Signed-off-by: Manojkiran Eda <manojkiran.eda@gmail.com>
Change-Id: I3f58dc4ba24ed43f30cca0c19b0235da5fb1435c
diff --git a/recipes-phosphor/bios/biosconfig-manager_git.bb b/recipes-phosphor/bios/biosconfig-manager_git.bb
new file mode 100644
index 0000000..dfe99f4
--- /dev/null
+++ b/recipes-phosphor/bios/biosconfig-manager_git.bb
@@ -0,0 +1,30 @@
+HOMEPAGE = "https://github.com/openbmc/bios-settings-mgr"
+
+SUMMARY = "Remote BIOS Configuration via BMC"
+
+DESCRIPTION = "Provides ability for the user to view and modify the BIOS setup \
+               configuration parameters remotely via BMC at any Host state. \
+               Modifications to the parameters take place upon the next system \
+               reboot or immediate based on the host firmware."
+
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bcd9ada3a943f58551867d72893cc9ab"
+
+SRC_URI = "git://github.com/openbmc/bios-settings-mgr"
+SRCREV = "8f706213ccc2900e1a02fedb26073065897b02c3"
+
+inherit meson pkgconfig systemd
+
+S = "${WORKDIR}/git"
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.biosconfig_manager.service \
+                         xyz.openbmc_project.biosconfig_password.service"
+
+DEPENDS = " boost \
+            phosphor-dbus-interfaces \
+            phosphor-logging \
+            sdbusplus \
+            systemd \
+            nlohmann-json "
+