phosphor-event: Convert options to config file
The systemd unit file for phosphor-event currently hard
codes the maximum buffer size.  Convert this to a systemd
EnvironmentFile so that it can more easily be replaced or
changed on individual systems.

Resolves openbmc/openbmc#216.

Change-Id: I17d471a872248190ca6eace41bc2ea41eb60bee6
Signed-off-by: Sergey Solomin <sergey.solomin@us.ibm.com>
diff --git a/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb b/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb
index eeb4a79..2ab7ce5 100644
--- a/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb
+++ b/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb
@@ -12,6 +12,7 @@
 TARGET_CPPFLAGS += "-std=c++11 -fpic"
 
 SRC_URI += "git://github.com/openbmc/phosphor-event"
+SRC_URI += "file://eventd.conf"
 
 SRCREV = "4dad23916e69d55d692eca7389d67eb023c5ca66"
 
@@ -26,4 +27,6 @@
         install -d ${D}/var/lib/obmc/events/
         install -m 0755 -d ${D}${sbindir}
         install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-eventd
+        install -m 0755 -d ${D}${sysconfdir}/default/eventd
+        install -m 0644 ${WORKDIR}/eventd.conf ${D}${sysconfdir}/default/eventd/eventd.conf
 }