meta-phosphor: Fix explicit dependencies antipattern

Out of the box bitbake examines built applications, automatically adds
runtime dependencies and thus ensures any library packages dependencies
are automatically added to images, sdks, etc.  There is no need to list
them explicitly in a recipe.

Dependencies change over time, and listing them explicitly is likely
prone to errors - the net effect being unnecessary shared library
packages being installed into images.

Consult
https://www.yoctoproject.org/docs/latest/mega-manual/mega-manual.html#var-RDEPENDS
for information on when to use explicit runtime dependencies.

Change-Id: Ica82c3dcea74467d9ac6528208b43249a24f0f29
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/recipes-phosphor/logging/ffdc_git.bb b/recipes-phosphor/logging/ffdc_git.bb
index c97afb7..81b7f45 100644
--- a/recipes-phosphor/logging/ffdc_git.bb
+++ b/recipes-phosphor/logging/ffdc_git.bb
@@ -6,8 +6,9 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
 
+DEPENDS += "systemd"
+
 RDEPENDS_${PN} += " \
-        systemd \
         ${VIRTUAL-RUNTIME_base-utils} \
         "