phosphor-post-code-manager: Add recipe file

Added initial recipe file for post code manager. It saves history
of post codes.

Change-Id: I628dbda1553a69458f1621dec10cf7a939ba8919
Signed-off-by: Vijay Khemka <vijaykhemka@fb.com>
diff --git a/recipes-phosphor/state/phosphor-post-code-manager_git.bb b/recipes-phosphor/state/phosphor-post-code-manager_git.bb
new file mode 100644
index 0000000..0bbf0e9
--- /dev/null
+++ b/recipes-phosphor/state/phosphor-post-code-manager_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Phosphor post code manager"
+DESCRIPTION = "Phosphor post Code Manager monitors post code posted on dbus \
+interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \
+in a file under /var/lib for history."
+
+SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git"
+SRCREV = "655837973feb51da3767f5f246ec198877900b0b"
+
+S = "${WORKDIR}/git"
+
+PV = "1.0+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit cmake pkgconfig systemd
+
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.State.Boot.PostCode.service"
+
+DEPENDS += " \
+    sdbusplus \
+    phosphor-dbus-interfaces \
+    phosphor-logging \
+    "