chassid/flashd: avoid QA issues with SRC_URI

The SRC_URI used ${PN} which can changed depending on target context,
such as appending "-native" or prepending "nativesdk-".  Use ${BPN}
instead.

Cleans up the following QA warnings with Tiogapass:
    WARNING: obmc-phosphor-flashd-1.0-r1 do_package_qa: QA Issue:
             obmc-phosphor-flashd: SRC_URI uses PN not BPN [src-uri-bad]

    WARNING: obmc-phosphor-chassisd-1.0-r1 do_package_qa: QA Issue:
             obmc-phosphor-chassisd: SRC_URI uses PN not BPN [src-uri-bad]

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I5a6501f5f0cd2ad649e09e85319e358a689f787f
diff --git a/recipes-phosphor/flash/obmc-phosphor-flashd.bb b/recipes-phosphor/flash/obmc-phosphor-flashd.bb
index 602dbe9..9287150 100644
--- a/recipes-phosphor/flash/obmc-phosphor-flashd.bb
+++ b/recipes-phosphor/flash/obmc-phosphor-flashd.bb
@@ -10,4 +10,4 @@
 RPROVIDES_${PN} += "virtual-obmc-flash-mgmt"
 
 S = "${WORKDIR}"
-SRC_URI += "file://${PN}.py"
+SRC_URI += "file://${BPN}.py"