recipes-x86: Add x86-power-control recipe

Change-Id: I2be82bc2640f84ae45d5a7600304acc6fd90e18d
Signed-off-by: Vijay Khemka <vijaykhemka@fb.com>
diff --git a/recipes-x86/chassis/x86-power-control_git.bb b/recipes-x86/chassis/x86-power-control_git.bb
new file mode 100755
index 0000000..d986ef1
--- /dev/null
+++ b/recipes-x86/chassis/x86-power-control_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Chassis Power Control service for Intel based platforms"
+DESCRIPTION = "Chassis Power Control service for Intel based platforms"
+
+SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=ssh"
+SRCREV = "f61ca6fdcc52beba485e014b5fad38a9e9a555ad"
+
+PV = "1.0+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit cmake systemd
+
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Chassis.Control.Power.service"
+
+DEPENDS += " \
+    boost \
+    i2c-tools \
+    libgpiod \
+    sdbusplus \
+    phosphor-logging \
+  "