meta-phosphor: update DEPENDS for sdbusplus-native

sdbusplus has changed the package layout so that sdbusplus-native and
sdbus++-native are now ${PYTHON_PN}-sdbus++-native.  Update recipes
that need to use sdbus++ (or its associated python modules) or remove
the DEPENDS if it is no longer necessary.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I30b17084af515647a42fcce3624a55c22e4a7172
diff --git a/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 94e8810..8c7eb55 100644
--- a/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -7,24 +7,21 @@
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
 
 inherit autotools pkgconfig
-inherit pythonnative
+inherit python3native
 inherit phosphor-dbus-yaml
 
 DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbus++-native"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
 
 SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces"
 SRCREV = "e08baa59447073895d1798fe054dfede3f842044"
 
-DEPENDS_remove_class-native = "sdbus++-native"
-DEPENDS_remove_class-nativesdk = "sdbus++-native"
-
 PACKAGECONFIG ??= "libphosphor_dbus"
 PACKAGECONFIG[libphosphor_dbus] = " \
         --enable-libphosphor_dbus, \
         --disable-libphosphor_dbus, \
         systemd sdbusplus, \
-        libsystemd sdbusplus \
+        libsystemd \
         "
 
 PACKAGECONFIG_remove_class-native = "libphosphor_dbus"