meta-phosphor: update DEPENDS for sdbusplus-native

sdbusplus has changed the package layout so that sdbusplus-native and
sdbus++-native are now ${PYTHON_PN}-sdbus++-native.  Update recipes
that need to use sdbus++ (or its associated python modules) or remove
the DEPENDS if it is no longer necessary.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I30b17084af515647a42fcce3624a55c22e4a7172
diff --git a/recipes-phosphor/logging/phosphor-logging_git.bb b/recipes-phosphor/logging/phosphor-logging_git.bb
index c65117d..9c59548 100644
--- a/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -18,7 +18,8 @@
 DEPENDS += "${PYTHON_PN}-mako-native"
 DEPENDS += "${PYTHON_PN}-pyyaml-native"
 DEPENDS += "${PYTHON_PN}-native"
-DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
+DEPENDS += "sdbusplus"
 DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
 DEPENDS += "virtual/phosphor-logging-callouts"
 DEPENDS += "phosphor-logging-error-logs-native"
@@ -63,7 +64,7 @@
 # as they will not be available in host machine
 DEPENDS_remove_class-native = " \
         virtual/phosphor-logging-callouts \
-        sdbus++ \
+        sdbusplus \
         systemd \
         libcereal \
         sdeventplus \
@@ -73,7 +74,7 @@
 # as they will not be available in host machine
 DEPENDS_remove_class-nativesdk = " \
         virtual/phosphor-logging-callouts \
-        sdbus++-native \
+        sdbusplus-native \
         libcereal \
         systemd \
         phosphor-dbus-interfaces \