ipmi: Remove virtual/phosphor-ipmi-fru-config

Replace this virtual with two others:
 -virtual/phosphor-ipmi-fru-hostfw-config
 -virtual/phosphor-ipmi-fru-inventory.

Update ipmi-fru-parser machine recipes to provide
virtual/phosphor-ipmi-fru-inventory rather than
virtual/phosphor-ipmi-fru-config.

Remove machine recipes on machines that use MRW
since a single MRW recipe provides for any MRW
using system automatically.

Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com?
Change-Id: Ia0d94b938eb2c7bfadd5a018ae5ea136f14dd874
diff --git a/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb b/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
index e0fcb0f..d6f8c8f 100644
--- a/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
+++ b/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
@@ -5,12 +5,17 @@
 inherit autotools pkgconfig
 inherit obmc-phosphor-systemd
 inherit obmc-phosphor-ipmiprovider-symlink
+inherit phosphor-ipmi-fru
+inherit pythonnative
 
 require ${PN}.inc
 
 DEPENDS += " \
-        virtual/phosphor-ipmi-fru-config \
+        virtual/phosphor-ipmi-fru-hostfw-config\
+        virtual/phosphor-ipmi-fru-inventory \
         systemd \
+        python-mako-native \
+        python-pyyaml-native \
         phosphor-ipmi-host \
         phosphor-mapper \
         autoconf-archive-native \
@@ -27,3 +32,12 @@
 FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
 FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
 FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+# TODO: Fix the the ipmi-fru-parser code generator to handle split
+# host firmware / inventory YAML and replace the OECONF below with:
+#
+# EXTRA_OECONF += "INVENTORY_YAML=${inventory_datadir}/config.yaml"
+# EXTRA_OECONF += "HOSTFW_YAML=${hostfw_datadir}/config.yaml"
+#
+# For now the generator requires them to already be combined so we have:
+EXTRA_OECONF = "YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml"