Add settings dbus object to openbmc image

Create settings recipe and service files
Add dependency to settings to the ipmid recipe
since the upcoming ipmi boot flags use this
settings dbus object
diff --git a/common/recipes-phosphor/settings/settings.bb b/common/recipes-phosphor/settings/settings.bb
new file mode 100644
index 0000000..1c5fe28
--- /dev/null
+++ b/common/recipes-phosphor/settings/settings.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Settings DBUS object"
+DESCRIPTION = "Settings DBUS object"
+HOMEPAGE = "http://github.com/openbmc/phosphor-settingsd"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+
+RDEPENDS_${PN} += "python-dbus python-pygobject"
+
+SRC_URI += "git://github.com/openbmc/phosphor-settingsd"
+
+SRCREV = "33e0930724c12f83ddf99f7452fc0551ac10ccfc"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+        install -d ${D}/${sbindir}
+        install ${S}/settings_file.py ${D}/${sbindir}
+        install ${S}/settings_manager.py ${D}/${sbindir}
+}
+