phosphor: Enable Aspeed SDK u-boot override

The u-boot SDK recipe in the Aspeed layer has different u-boot config
snippets for different sized flash images.  This is done by way of
overrides, e.g.

  MACHINEOVERRIDES .= ":flash-${ASPEED_IMAGE_SIZE_KB}"

Make sure ASPEED_IMAGE_SIZE_KB is set to the correct size so the correct
u-boot snippet is selected.

Change-Id: I0bd6f8fc1a6c759eeb14f3a89000f0f8b27ed2b7
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/aspeed-layer/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend b/aspeed-layer/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
new file mode 100644
index 0000000..0e18a7c
--- /dev/null
+++ b/aspeed-layer/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
@@ -0,0 +1,2 @@
+FLASH_SIZE ?= "32768"
+ASPEED_IMAGE_SIZE_KB = "${FLASH_SIZE}"