phosphor-base.inc: add var for automatic YAML subdirs
Some packages have directory trees of YAML files arranged based on
canonical organization names. See
phosphor-logging-yaml-providers.bbclass as an example.
Add a variable that can be appended to by a layer to limit the number
of 'bbappends' that are necessary in a layer to add their
layer-specific organizations to all the YAML processing recipes.
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I826cb3cd5623f4c8e635502cd9b1020c9df8ecb5
diff --git a/classes/phosphor-logging-yaml-provider.bbclass b/classes/phosphor-logging-yaml-provider.bbclass
index f18adbb..89d031c 100644
--- a/classes/phosphor-logging-yaml-provider.bbclass
+++ b/classes/phosphor-logging-yaml-provider.bbclass
@@ -1,6 +1,6 @@
inherit phosphor-dbus-yaml
-LOGGING_YAML_SUBDIRS ??= "xyz/openbmc_project"
+LOGGING_YAML_SUBDIRS ??= "${OBMC_ORG_YAML_SUBDIRS}"
do_install_append() {
for yaml_d in ${LOGGING_YAML_SUBDIRS} ;