Enable support for usecase specific bash script invocation

Resolves openbmc/openbmc#2037

Install dreport, dreport.conf, plugins
Parse the scripts to fetch config value
Create user directories based on config value with
softlinks to the plugins

Change-Id: If1bdefca362a282132364306b26eecb4b7003390
Signed-off-by: Marri Devender Rao <devenrao@in.ibm.com>
diff --git a/classes/phosphor-debug-collector.bbclass b/classes/phosphor-debug-collector.bbclass
index 2a2a3a4..d5d49a2 100644
--- a/classes/phosphor-debug-collector.bbclass
+++ b/classes/phosphor-debug-collector.bbclass
@@ -1 +1,5 @@
 bmc_dump_path="/var/lib/phosphor-debug-collector/dumps"
+dreport_plugin_dir = "${datadir}/dreport.d/plugins.d"
+dreport_include_dir = "${datadir}/dreport.d/include.d"
+dreport_conf_dir = "${datadir}/dreport.d/conf.d"
+dreport_dir = "${datadir}/dreport.d/"