Initial recipe for phosphor-version-software-manager

Change-Id: I940fe53d276f2ebfe05fd70cc2ec26a485348e29
Signed-off-by: Gunnar Mills <gmills@us.ibm.com>
diff --git a/common/recipes-phosphor/flash/phosphor-software-manager.bb b/common/recipes-phosphor/flash/phosphor-software-manager.bb
new file mode 100644
index 0000000..d0c9b5e
--- /dev/null
+++ b/common/recipes-phosphor/flash/phosphor-software-manager.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Phosphor Software Management"
+DESCRIPTION = "Phosphor Software Manager provides a set of system software \
+management daemons. It is suitable for use on a wide variety of OpenBMC \
+platforms."
+HOMEPAGE = "https://github.com/openbmc/phosphor-bmc-code-mgmt"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SOFTWARE_MGR_PACKAGES = " \
+    ${PN}-version \
+"
+PACKAGE_BEFORE_PN = "${PN}-version"
+DBUS_PACKAGES = "${SOFTWARE_MGR_PACKAGES}"
+
+# Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES
+# handles the rest.
+SYSTEMD_PACKAGES = ""
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-dbus-service
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-dbus-interfaces"
+
+RDEPENDS_${PN}-version += "phosphor-dbus-interfaces sdbusplus"
+
+FILES_${PN}-version = "${sbindir}/phosphor-version-software-manager"
+DBUS_SERVICE_${PN}-version += "xyz.openbmc_project.Software.Version.service"
+
+SRC_URI += "git://github.com/openbmc/phosphor-bmc-code-mgmt"
+SRCREV = "af4759e828690e51035c9d11c2a6845d9bb38406"
+
+S = "${WORKDIR}/git"