Tell phosphor-logging about the sw-mgr error yaml

This needs to be done so phosphor-logging will know to grab
the error log's metadata from the journal and add it to
the log in the AdditionalData field.

Tested: Check that the errors now show up in the elog-lookup.cpp
        file generated during the build by phosphor-logging.

Change-Id: I59e357986ac56ea752c9f7241a5138eb4985ceb6
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/common/recipes-phosphor/flash/phosphor-software-manager.bb b/common/recipes-phosphor/flash/phosphor-software-manager.bb
index e23e893..5527706 100644
--- a/common/recipes-phosphor/flash/phosphor-software-manager.bb
+++ b/common/recipes-phosphor/flash/phosphor-software-manager.bb
@@ -2,10 +2,9 @@
 DESCRIPTION = "Phosphor Software Manager provides a set of system software \
 management daemons. It is suitable for use on a wide variety of OpenBMC \
 platforms."
-HOMEPAGE = "https://github.com/openbmc/phosphor-bmc-code-mgmt"
 PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+require ${PN}.inc
 
 SOFTWARE_MGR_PACKAGES = " \
     ${PN}-version \
@@ -86,7 +85,4 @@
     fi
 }
 
-SRC_URI += "git://github.com/openbmc/phosphor-bmc-code-mgmt"
-SRCREV = "56aaf454adef04bd4c1d45870cd86dc2de0a880a"
-
 S = "${WORKDIR}/git"