Fix compile issue for X86 SDK

Some systems do not have a workbook in skeleton so
modify the obmc-mgr-inventory recipe to just use
an empty one in these cases.

Resolves openbmc/openbmc#1477

Change-Id: Ib634e70d002194f2a5d0428b4f1df947948fd6c9
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/common/recipes-phosphor/chassis/obmc-mgr-inventory.bb b/common/recipes-phosphor/chassis/obmc-mgr-inventory.bb
index aa9f6b4..452faa3 100644
--- a/common/recipes-phosphor/chassis/obmc-mgr-inventory.bb
+++ b/common/recipes-phosphor/chassis/obmc-mgr-inventory.bb
@@ -7,6 +7,8 @@
 
 RRECOMMENDS_${PN} += "virtual-obmc-inventory-data"
 
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
 RDEPENDS_${PN} += "\
         python-argparse \
         python-dbus \