phosphor-ipmi-host: Move configuration to phosphor-ipmi-config

Witherspoon requires an dev_id.json file whose content is partially
derived from data provided by the os-release package. os-release is
updated for each commit, as some of its content (VERSION and
VERSION_ID) can be derived from `git describe`. As dev_id.json was
provided by the phosphor-ipmi-host package, every commit transitively
triggered a rebuild of phosphor-ipmi-host in order to satisfy
Witherspoon's requirements.

Always rebuilding phosphor-ipmi-host is unhelpful for several reasons:

* It needlessly reduces CI throughput, as it is likely the commits in
  question do not modify the phosphor-ipmi-host package.
* GCC suffers from what appears to be an unfixable[1] bug[2] that causes
  phoshor-ipmi-host to consume large (>5GiB) amounts of RAM when
  compiling some (at least Witherspoon) sensor configurations.

To avoid this, separate the configuration files out into
virtual/phosphor-ipmi-config and phosphor-ipmi-config packages that
phosphor-ipmi-host RDEPENDS on. Witherspoon provides an alternative
implementation in witherspoon-ipmi-config to mangle dev_id.json to its
particular requirements.

A virtual is used rather than a simple bbappends for Witherspoon, as the
bbappend approach breaks builds of machines other than Witherspoon if
Witherspoon is built first: The Witherspoon-specific dev_id.json file is
deployed in its mangled form into e.g. a Zaius image. Specifically, the
following sequence will trigger the issue:

    $ TEMPLATECONF=.../witherspoon.conf . openbmc-env
    $ bitbake obmc-phosphor-image
    $ rm -rf conf
    $ TEMPLATECONF=.../zaius.conf . openbmc-env
    $ bitbake obmc-phosphor-image

[1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80290#c26
[2] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80290

Change-Id: Ib9629fc77b29e2deeab3f1c3a145d9e966c14ec4
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
diff --git a/common/recipes-phosphor/ipmi/phosphor-ipmi-config.bb b/common/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
new file mode 100644
index 0000000..933fd3b
--- /dev/null
+++ b/common/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Phosphor IPMI daemon configuration"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit allarch
+
+SRC_URI = " \
+    file://cipher_list.json \
+    file://dcmi_cap.json \
+    file://dcmi_sensors.json \
+    file://dev_id.json \
+    file://power_reading.json \
+    "
+
+FILES_${PN} = " \
+    ${datadir}/ipmi-providers/cipher_list.json \
+    ${datadir}/ipmi-providers/dcmi_cap.json \
+    ${datadir}/ipmi-providers/dcmi_sensors.json \
+    ${datadir}/ipmi-providers/dev_id.json \
+    ${datadir}/ipmi-providers/power_reading.json \
+    "
+
+do_fetch[noexec] = "1"
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+    install -d ${D}${datadir}/ipmi-providers
+    install -m 0644 -D ${WORKDIR}/cipher_list.json \
+        ${D}${datadir}/ipmi-providers/cipher_list.json
+    install -m 0644 -D ${WORKDIR}/dcmi_cap.json \
+        ${D}${datadir}/ipmi-providers/dcmi_cap.json
+    install -m 0644 -D ${WORKDIR}/dcmi_sensors.json \
+        ${D}${datadir}/ipmi-providers/dcmi_sensors.json
+    install -m 0644 -D ${WORKDIR}/dev_id.json \
+        ${D}${datadir}/ipmi-providers/dev_id.json
+    install -m 0644 -D ${WORKDIR}/power_reading.json \
+        ${D}${datadir}/ipmi-providers/power_reading.json
+}