phosphor-mapper: Add service namespaces

The c++ mapper implements a dbus service namespace whitelist instead of
a path namespace whitelist.  A service namespace whitelist significantly
reduces the amount of introspection required by the mapper as compared
to path namespaces.

Add the service namespace whitelist to the mapper command line in the
mapper systemd unit and extend the existing framework for specifying
mapper command line arguments to include a service namespace whitelist.

Note that support for a _service_ blacklist is added and _path_ and
_interface_ blacklists are not being re-introduced.

Change-Id: Ia4636d338af2f87c7bc2a5041bcb685bca895060
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/recipes-phosphor/dbus/phosphor-mapper-config-native.bb b/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
index dcc5bd3..9e2f43f 100644
--- a/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
+++ b/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
@@ -24,10 +24,17 @@
 # Add path namespaces to be monitored.
 PHOSPHOR_MAPPER_NAMESPACE = ""
 
+# Add services to be monitored.
+PHOSPHOR_MAPPER_SERVICE = ""
+
 # Add interfaces to be monitored.
 PHOSPHOR_MAPPER_INTERFACE = ""
 
+# Blacklist services from being monitored.
+PHOSPHOR_MAPPER_SERVICE_BLACKLIST = ""
+
 do_install() {
         install -d ${D}/${namespace_dir}
         install -d ${D}/${interface_dir}
+        install -d ${D}/${serviceblacklist_dir}
 }