phosphor-power: Add phosphor-regulators-config service

Add the phosphor-regulators config service that performs a method call
to phosphor-regulators that would then configure the regulators. This
service should be called immediately at poweron before the power
sequencing begins.

Tested:
    Method call occurs before pre-poweron target is set
    Power sequencing does not start before this method completes

Change-Id: I091c7176d7dd07166fb18a386bf88a67e5995580
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/recipes-phosphor/power/phosphor-power_git.bb b/recipes-phosphor/power/phosphor-power_git.bb
index ab704ad..b7bcfd3 100644
--- a/recipes-phosphor/power/phosphor-power_git.bb
+++ b/recipes-phosphor/power/phosphor-power_git.bb
@@ -48,11 +48,12 @@
 PSU_MONITOR_TMPL = "power-supply-monitor@.service"
 PSU_MONITOR_SVC = "phosphor-psu-monitor.service"
 REGS_SVC = "phosphor-regulators.service"
+REGS_CONF_SVC = "phosphor-regulators-config.service"
 
 SYSTEMD_SERVICE_${PN}-sequencer = "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC}"
 SYSTEMD_SERVICE_${PN}-monitor = "${PSU_MONITOR_TMPL}"
 SYSTEMD_SERVICE_${PN}-psu-monitor = "${PSU_MONITOR_SVC}"
-SYSTEMD_SERVICE_${PN}-regulators = "${REGS_SVC}"
+SYSTEMD_SERVICE_${PN}-regulators = "${REGS_SVC} ${REGS_CONF_SVC}"
 
 
 # TODO: cold-redundancy is not installed in the repo yet