Create symlink for IPMI Provider libraries

The IPMI provider libraries are installed into /usr/lib/ipmid-providers.
If the provider library is applicable for host-ipmid channel then soft
link is created to /usr/lib/host-ipmid. In this way the soft links are
created for the provider library to the corresponding directory.

Change-Id: I586bc830efd2b1d1ff1941181d1aa8d9a400f628
Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
diff --git a/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb b/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
index d053bce..e0fcb0f 100644
--- a/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
+++ b/common/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
@@ -4,6 +4,7 @@
 
 inherit autotools pkgconfig
 inherit obmc-phosphor-systemd
+inherit obmc-phosphor-ipmiprovider-symlink
 
 require ${PN}.inc
 
@@ -21,5 +22,8 @@
 
 S = "${WORKDIR}/git"
 
+HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
 FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
-FILES_${PN}-dev_append = " ${libdir}/host-ipmid/lib*${SOLIBSDEV} ${libdir}/host-ipmid/*.la"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"