Add root user to required groups as per recipe

root user has to be added to groups accordingly based
on the recipe. i.e. phosphor-ipmi-host_git.bb, will create
both ipmi group, and add root user to the same.

Unit-test:
1. Verified root user is added to the groups accordingly.

Change-Id: I047ea54243dcd950275cb3c58c2e78b218293763
Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
diff --git a/recipes-phosphor/users/phosphor-user-manager_git.bb b/recipes-phosphor/users/phosphor-user-manager_git.bb
index 6f65fee..1e9747a 100644
--- a/recipes-phosphor/users/phosphor-user-manager_git.bb
+++ b/recipes-phosphor/users/phosphor-user-manager_git.bb
@@ -26,6 +26,10 @@
 # add groups needed for privilege maintenance
 GROUPADD_PARAM_${PN} = "priv-admin; priv-operator; priv-user; priv-callback "
 GROUPADD_PARAM_phosphor-ldap = "priv-admin; priv-operator; priv-user; priv-callback "
+
+# Add root user to priv-admin group
+GROUPMEMS_PARAM_${PN} = "-g priv-admin -a root"
+
 DBUS_SERVICE_${PN} += "xyz.openbmc_project.User.Manager.service"
 FILES_phosphor-ldap += " \
         ${sbindir}/phosphor-ldap-conf \