phosphor: net-snmp: clean up configure options
Remove a number of configure option overrides to reduce maintainence
burden.
Remove disable-manuals because the base recipe already does that.
The disable-embedded-perl and disable-perl-cc-checks options are
unnecessary because the perl PACKAGECONFIG is not enabled by default in
the base recipe.
Remove disable-libtool-lock. The configure script has this to say
about this option:
avoid locking (might break parallel builds)
bitbake builds with make -j so it seems like a good idea to stick with
the default, and build with libtool locking enabled. This option has
no runtime effect.
Remove disable-deprecated. This option is unused by net-snmp. Just
use the default to minimize the maintainence delta. It has no runtime
effect.
Remove disable-privacy. Encryption isn't used at the moment but the
footprint impact on libnetsnmp to leave it at the default (enabled)
is negligible ( < ~10K stripped, uncompressed ).
Remove disable-set-support and disable-snmptrapd-subagent. These are
agent functions which are currently unused. Leave at the default.
Remove disable-scripts. This does grow the client package but the
client package is not used at the moment. Leave at the default.
Change-Id: Ifac0c6c1a30ba4189e55eee2d3368a447f6703da
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/recipes-protocols/net-snmp/net-snmp_%.bbappend b/recipes-protocols/net-snmp/net-snmp_%.bbappend
index d137d29..50ef9a3 100644
--- a/recipes-protocols/net-snmp/net-snmp_%.bbappend
+++ b/recipes-protocols/net-snmp/net-snmp_%.bbappend
@@ -1,6 +1,6 @@
EXTRA_OECONF += "--disable-mib-loading \
---disable-manuals --disable-scripts --disable-embedded-perl \
---disable-perl-cc-checks --disable-libtool-lock --disable-debugging \
---disable-snmpv1 --disable-des --disable-privacy --disable-md5 \
---disable-snmptrapd-subagent --disable-set-support --disable-deprecated \
-"
+ --disable-debugging \
+ --disable-md5 \
+ --disable-des \
+ --disable-snmpv1 \
+ "