phosphor-ipmi-host: Add entity config default

To provide a custom entity configuration, provide
a virtual phosphor-ipmi-entity-config. The entity.yaml file contains
metadata information for the SDR type 0x08h (Entity Association Record)

Change-Id: Ib78a1e2798b49434479b5459ca9bc96ccfdb66ae
Signed-off-by: Jaghathiswari Rankappagounder Natarajan <jaghu@google.com>
diff --git a/recipes-phosphor/ipmi/phosphor-ipmi-entity-inventory-native.bb b/recipes-phosphor/ipmi/phosphor-ipmi-entity-inventory-native.bb
new file mode 100644
index 0000000..acc693e
--- /dev/null
+++ b/recipes-phosphor/ipmi/phosphor-ipmi-entity-inventory-native.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Sample entity configuration for phosphor-host-ipmid"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+inherit phosphor-ipmi-host
+
+PROVIDES += "virtual/phosphor-ipmi-entity-config"
+
+SRC_URI += "file://entity.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+        # This recipe is supposed to create an output yaml file with
+        # a sample output file.
+
+        DEST=${D}${sensor_datadir}
+        install -d ${DEST}
+        install entity.yaml ${DEST}/entity.yaml
+}