sdbusplus: switch to generic python package ver

Rather than reference "python-foo" for recipe dependencies,
switch to "${PYTHON_PN}-foo" syntax, which is used throughout
other example Yocto recipes to aid a simple transition from
python2 to python3.

This variable is set up by pythonnative -> python-dir includes
already.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ice7a6655ba2cc59bbd005c7ac2b1295df5e84b03
diff --git a/recipes-extended/sdbusplus/sdbusplus_git.bb b/recipes-extended/sdbusplus/sdbusplus_git.bb
index 5c285f2..a54ba6e 100644
--- a/recipes-extended/sdbusplus/sdbusplus_git.bb
+++ b/recipes-extended/sdbusplus/sdbusplus_git.bb
@@ -11,14 +11,15 @@
 
 DEPENDS += " \
         autoconf-archive-native \
-        python-inflection-native \
-        python-mako-native \
-        python-pyyaml-native \
+        ${PYTHON_PN}-inflection-native \
+        ${PYTHON_PN}-mako-native \
+        ${PYTHON_PN}-pyyaml-native \
         "
 RDEPENDS_sdbus++ += " \
-        python-inflection \
-        python-mako \
-        python-pyyaml \
+        ${PYTHON_PN} \
+        ${PYTHON_PN}-inflection \
+        ${PYTHON_PN}-mako \
+        ${PYTHON_PN}-pyyaml \
         "
 
 # sdbus++ has a handful of runtime dependencies on other python packages.
@@ -31,9 +32,9 @@
 # on sdbus++ runtime dependencies manually.
 
 DEPENDS_append_class-native = " \
-        python-inflection-native \
-        python-mako-native \
-        python-pyyaml-native \
+        ${PYTHON_PN}-inflection-native \
+        ${PYTHON_PN}-mako-native \
+        ${PYTHON_PN}-pyyaml-native \
         "
 
 SRC_URI += "git://github.com/openbmc/sdbusplus"