Add phosphor-power recipe

There was witherspoon-fault-analysis recipe in meta-ibm. Now the repo
becomes a generic one, phosphor-power, add the recipe in meta-phosphor.

Tested: Verify the build `bitbake phosphor-power` succeeds.
        With changes in meta-ibm/meta-witherspoon, verify phosphor-power
        is built correctly and the services are installed.

Change-Id: I08b2bc2b13d80d1290a970f48565be18728a2115
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/recipes-phosphor/power/phosphor-power_git.bb b/recipes-phosphor/power/phosphor-power_git.bb
new file mode 100644
index 0000000..b66c107
--- /dev/null
+++ b/recipes-phosphor/power/phosphor-power_git.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Phosphor Power services and utilities"
+DESCRIPTION = "Configure and monitor power supplies, power sequencers, and \
+voltage regulators, and analyzes power devices for faults"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit meson
+inherit pkgconfig
+inherit systemd
+inherit pythonnative
+
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+
+# TODO: in future when openpower-dbus-interfaces is removed from
+# phosphor-power, remove the dependency here.
+DEPENDS += " \
+         phosphor-logging \
+         openpower-dbus-interfaces \
+         sdbus++-native \
+         sdeventplus \
+         nlohmann-json \
+         "
+
+SEQ_MONITOR_SVC = "pseq-monitor.service"
+SEQ_PGOOD_SVC = "pseq-monitor-pgood.service"
+PSU_MONITOR_TMPL = "power-supply-monitor@.service"
+SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC} ${PSU_MONITOR_TMPL}"