phosphor-dbus-interfaces: remove unused PACKAGECONFIG

The libphosphor_dbus was previously used in native/nativesdk targets
in order to prevent the library from being built (and to only export
YAML).  This PACKAGECONFIG is no longer necessary.  Remove it to
simplify the recipe and the [eventually] the underlying repository.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I60c6a5f18c92f8c16cd2dc343cdbb034a8830a02
diff --git a/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 9743f3c..658843b 100644
--- a/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -10,16 +10,12 @@
 inherit python3native
 inherit phosphor-dbus-yaml
 
-DEPENDS += "autoconf-archive-native"
-DEPENDS += "${PYTHON_PN}-sdbus++-native"
+DEPENDS += " \
+        ${PYTHON_PN}-sdbus++-native \
+        autoconf-archive-native \
+        sdbusplus \
+        systemd \
+        "
 
 SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces"
 SRCREV = "11699d678d4166ff4b23900f31794754f305df64"
-
-PACKAGECONFIG ??= "libphosphor_dbus"
-PACKAGECONFIG[libphosphor_dbus] = " \
-        --enable-libphosphor_dbus, \
-        --disable-libphosphor_dbus, \
-        systemd sdbusplus, \
-        libsystemd \
-        "