witherspoon: Update image location for software manager

Update witherspoon to store new software bmc images in the
bmc and alternate chip, use the plus sign (+) as separator
since that one doesn't conflict with the build substitution
function and shell scripting.
Set the default location for bmc images to the bmc chip now
that the listed issues have been resolved.

Change-Id: I7cfe9977bde580f571418d5ea450e58b562d2799
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/common/recipes-phosphor/flash/phosphor-software-manager.bb b/common/recipes-phosphor/flash/phosphor-software-manager.bb
index e287797..324474b 100644
--- a/common/recipes-phosphor/flash/phosphor-software-manager.bb
+++ b/common/recipes-phosphor/flash/phosphor-software-manager.bb
@@ -76,11 +76,9 @@
     "
 
 # Name of the mtd device where the ubi volumes should be created
-BMC_RW_MTD ??= "pnor"
-BMC_RO_MTD ??= "pnor"
-# TODO Change kernel location to primary BMC chip once the rofs/rwfs mtd devices
-# are merged into a single ubi one openbmc/openbmc#1942
-BMC_KERNEL_MTD ??= "pnor"
+BMC_RW_MTD ??= "bmc"
+BMC_RO_MTD ??= "bmc"
+BMC_KERNEL_MTD ??= "bmc"
 SYSTEMD_SUBSTITUTIONS += "RW_MTD:${BMC_RW_MTD}:obmc-flash-bmc-ubirw.service"
 SYSTEMD_SUBSTITUTIONS += "RO_MTD:${BMC_RO_MTD}:obmc-flash-bmc-ubiro@.service"
 SYSTEMD_SUBSTITUTIONS += "KERNEL_MTD:${BMC_KERNEL_MTD}:obmc-flash-bmc-ubiro@.service"